Delays in learner progress
Incident Report for Coursera
Resolved
This incident has been resolved.
Posted Mar 22, 2020 - 21:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2020 - 20:17 PDT
Investigating
We are experiencing issues with displaying assignment progress. Your progress is being saved in our system and should appear soon.
Posted Mar 22, 2020 - 13:40 PDT