Coursera site-wide loading issues
Incident Report for Coursera
Resolved
All pages should be back and loading normally
Posted Apr 02, 2018 - 19:05 PDT
Investigating
We are currently experiencing loading errors across all pages, and are currently looking into the issue.
Posted Apr 02, 2018 - 18:55 PDT