Some interruptions on Coursera

Incident Report for Coursera

Resolved

This incident has been resolved.
Posted Dec 16, 2024 - 13:22 PST

Investigating

Some learners are experiencing interruptions on Coursera. We are investigating and working to resolve.
Posted Dec 16, 2024 - 09:36 PST