Issue impacting some assessments

Incident Report for Coursera

Resolved

This incident has been resolved.
Posted Jul 30, 2024 - 22:00 PDT

Investigating

Learners may experience some issues with viewing or submitting assessments and viewing progress or grades. We apologize for the inconvenience and are working on resolving the issue.
Posted Jul 30, 2024 - 17:33 PDT