Coursera.org currently unavailable

Incident Report for Coursera

Resolved

This incident has been resolved.
Posted Oct 09, 2024 - 11:02 PDT

Investigating

Coursera.org is currently unavailable, and we are working to resolve the issue.
Posted Oct 09, 2024 - 10:48 PDT