Coursera platform not loading. Began around 11:05am PT
Incident Report for Coursera
Resolved
This site-wide outages are now resolved. Platform notifications will remain off until further notice.
Posted Mar 12, 2018 - 18:25 PDT
Monitoring
Platform features have been restored apart from notifications. We are monitoring for stability.
Posted Mar 12, 2018 - 15:49 PDT
Update
Peer reviews have been restored.
Posted Mar 12, 2018 - 15:32 PDT
Update
Search has been restored.
Posted Mar 12, 2018 - 15:14 PDT
Update
Some features remain unavailable including course search, peer review, Coursera for Business administrator dashboard and membership overview.
Posted Mar 12, 2018 - 14:43 PDT
Update
Most course services have resumed. We are still experiencing outages across our course search as well as our Coursera for Business administrator dashboards.
Posted Mar 12, 2018 - 13:08 PDT
Identified
The issue has been identified and our engineers are working on resolving as soon as possible. Areas affected include course search, course progress, discussion forums, and our Coursera for Business administrative dashboards.
Posted Mar 12, 2018 - 12:06 PDT
Investigating
Our engineers are currently investigating this platform-wide issue.
Posted Mar 12, 2018 - 11:28 PDT