Some forums not loading
Incident Report for Coursera
Resolved
at 3:06pm EST this issue has been resolved. Some learners may have experienced issues when searching the catalog in addition to forums not loading periodically.
Posted Sep 17, 2018 - 16:07 PDT
Identified
Learners may encounter an issue with forums pages not loading. Our team is investigating. Please check back in 30 minute.
Posted Sep 17, 2018 - 13:35 PDT