Coursera will be performing site-wide maintenance
Incident Report for Coursera
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 23:03 PDT
Update
Coursera is currently performing scheduled maintenance and may be unavailable until 11 P.M. Pacific Time. Thank you for your patience as we work to enhance your learning experience on Coursera.
Posted Apr 02, 2020 - 21:02 PDT
Update
Coursera will be performing site-wide maintenance starting April 2, 2020, at 9 P.M. Pacific Time and will be unavailable for up to two hours.
Posted Apr 02, 2020 - 20:57 PDT
Identified
Preparing for site-wide maintenance.
Posted Apr 02, 2020 - 20:32 PDT