Help Centers Not Loading
Incident Report for Coursera
Resolved
This incident has been resolved.
Posted Jun 12, 2018 - 13:45 PDT
Monitoring
Our Help Center content is currently inaccessible due to an outage in the help center software. We anticipate this will be restored shortly, and appreciate your patience at this time.
Posted Jun 12, 2018 - 13:20 PDT