Sitewide outage
Incident Report for Coursera
Resolved
This issue has been resolved, and all coursera.org pages should load normally.
Posted May 04, 2020 - 22:17 PDT
Investigating
Coursera.org is currently not loading. We apologize for the inconvenience and are investigating the issue.
Posted May 04, 2020 - 21:33 PDT