Coursera.org is experiencing interruptions

Incident Report for Coursera

Resolved

This incident has been resolved.
Posted Jun 15, 2023 - 13:37 PDT

Investigating

We are seeing issues with the Coursera.org homepage not loading and are working to resolve these issues as soon as possible.
Posted Jun 15, 2023 - 13:08 PDT