Coursera site is currently down

Incident Report for Coursera

Resolved

Coursera platform is back to fully operational, thank you for your patience and understanding.
Posted Oct 20, 2025 - 15:42 PDT

Monitoring

AWS has not yet achieved full recovery, but we are seeing continued stabilization of the Coursera platform as more parts of the platform are regaining functionality. We will continue to monitor and work towards full recovery.
Posted Oct 20, 2025 - 14:47 PDT

Identified

AWS services are in the process of being restored, and we are working to restore Coursera access as soon as possible.
Posted Oct 20, 2025 - 11:47 PDT

Investigating

Our site is currently down due to a widespread Amazon AWS service outage. We are working to restore access as soon as possible, thank you for your patience.
Posted Oct 20, 2025 - 08:38 PDT