Coursera.org unavailable
Incident Report for Coursera
Resolved
Coursera.org is now available. Thank you for your patience while we resolved the issue, and we apologize for the inconvenience.
Posted Jun 03, 2020 - 14:06 PDT
Investigating
Coursera.org is currently unavailable, and we are working to resolve the issue. We apologize for the inconvenience.
Posted Jun 03, 2020 - 11:20 PDT