Coursera.org is experiencing interruptions

Incident Report for Coursera

Resolved

This incident has been resolved.
Posted 16 days ago. Apr 07, 2025 - 15:00 PDT

Investigating

Certain features on Coursera.org are currently unavailable, and we are working to resolve the issue.
Posted 16 days ago. Apr 07, 2025 - 14:40 PDT