Enroll button results in error for some learners
Incident Report for Coursera
Resolved
This incident has been resolved.
Posted Apr 09, 2020 - 19:42 PDT
Update
This issue has been resolved.
Posted Apr 09, 2020 - 19:42 PDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2020 - 19:18 PDT